Back to overview
Downtime
Network Connectivity Issues
Feb 11 at 11:43am CST
Affected services
myTPSA
Admin
API
Workers
Agreements App/Member Cards
Website
CMS
Resolved
Feb 11 at 03:42pm CST
Services have returned to normal operations.
Affected services
Created
Feb 11 at 11:43am CST
Our upstream technology/server providers are experiencing network connectivity errors which is affecting our services. Our main website, applications, etc may be slow to load or not load at all while this is incident is still happening.
Affected services